Home » Infrastructure » Linux » Upgrading RHEL AS 4 2.6.9-5.0.5 up to 2.6.9-11 running Oracle's 10g ASM instance
Upgrading RHEL AS 4 2.6.9-5.0.5 up to 2.6.9-11 running Oracle's 10g ASM instance [message #132544] Sun, 14 August 2005 09:35
DbaRnd
Messages: 1
Registered: August 2005
Junior Member
Remove old "oracleasm" library to be able to upgrade kernel:-

# rpm -e oracleasm-2.6.9-5.0.5.ELsmp-2.0.0-1 \
oracleasmlib-2.0.0-1 \
oracleasm-support-2.0.0-1

Perform kernel upgrade :-

# rpm -Uvh kernel-2.6.9-11.EL.i686.rpm
# rpm -Uvh kernel-smp-2.6.9-11.EL.i686.rpm
# rpm -Uvh kernel-2.6.9-11.EL.src.rpm
# rpm -Uvh kernel-devel-2.6.9-11.EL.i686.rpm
# rpm -Uvh kernel-smp-devel-2.6.9-11.EL.i686.rpm
# rpm -Uvh kernel-hugemem-2.6.9-11.EL.i686.rpm
# rpm -Uvh kernel-hugemem-devel-2.6.9-11.EL.i686.rpm
# rpm -Uvh kernel-doc-2.6.9-11.EL.noarch.rpm

Doble check packages installation :-

# rpm -qa | grep kernel

Install new version "oracleasm" library :-

# rpm -Uvh oracleasm-2.6.9-11.ELsmp-2.0.0-1.i686.rpm \
oracleasmlib-2.0.0-1.i386.rpm \
oracleasm-support-2.0.0-1.i386.rpm

# /etc/init.d/oracleasm configure

failure to load "oracleasm" module is expected

# /etc/init.d/oracleasm enable

failure to load "oracleasm" module is expected

# reboot

Check for successful loading "oracleasm" module during system boot.
Versions of kernel and library now match.
Make sure all volumes are present in new environment.

# /etc/init.d/oracleasm listdisks
# su - oracle
# ps -ef | grep css
If CRS daemons are already up and running:-

oracle@ServerFDR$ dbstart
Previous Topic: vb-xml-databse
Next Topic: what is the parameters need to be mentioned when creating a Oracle9i database on Redhat Linux9
Goto Forum:
  


Current Time: Mon Apr 12 20:08:59 CDT 2021